Pipeline error in the branch training

Good afternoon I have some errors when executing the pipe.

The first error is that it tells me to use “raw” in the url and implement it with “raw.githack”, but the pipeline does not accept it

The second error is with respect to the code, I use pylint and ESlint and it doesn’t give me any code error, but when I run the pipe if it generates several code errors, then I don’t know what to do about it.

I’m looking at the errors and it seems pretty clear about what you could do about it:

code/hackerrank/birthdaycakecandles/birthday_cake_candles.py
 [ERROR] Paths contain characters outside of ^[a-zA-Z0-9.\-/]*$

This one may be a little tricky, there is a redirection at the last URL, that’s why the 301

 [OK] HTTP 200 in OTHERS.lst, url: 'https://raw.githubusercontent.com/anujdutt9/Hackerrank/master/Python3%20Code/Birthday-Cake-Candles.py'
 [ERROR] HTTP 301 in OTHERS.lst, url: 'https://raw.githack.com/wjmandella/Birthday-Cake-Candles/master/src/BirthdayCakeCandlesApp.java'
 [INFO] Executing function: job_check_commit_message
 ⧗   input: sol(code): #0 hackerrank, birthdaycakecandles (easy)
 - others: 0 in, 5 out, 5 total.
 - score: 65 initial, 67 final, 2 progress.
 - global-rank: 296196 initial, 226104 final, 700.92 progress.
 - national-rank: 234008 initial, 226260 final, 7748 progress.
 - effort: 4 hours during challenges, productivity 0.5 points/hour.
 ✖   header must not be longer than 50 characters, current length is 52 [header-max-length]
 ✖   found 1 problems, 0 warnings

if pylint and ESLint passes locally but not at the CI, it’s because you may have the wrong configurations
we use pylint for python3, and ESLint with the eslint-config-strict plugin.

moreover, as the error messages say:

 We have found some problems with your commit
   You can replicate this output locally with:
     training $ ./build.sh check_commit_message

more documentation about running ./build.sh as a way to replicate environments:

that’s the only way we support for talents to run the checks locally

1 Like

Hello everyone, about the paths, recently i had the same error that was:
Captura de Pantalla 2020-08-01 a la(s) 21.55.29
I dont understand well about the HTTP 200. what could i do?
https://gitlab.com/autonomicmind/challenges/-/jobs/667003257

You must see the regex and compare it with the paths and filenames of your files, you can find the problem with that.

Hi @pastel-code, the file of my solution could has any capital letter?

No, the regex say that all letters must be in lowercase

1 Like