Build.sh installation error with curl

Good morning, I have a problem with the installation of the curl when I install the build.sh and the problem is that the installation of the curl https://nixos.org/nix/install , does not work, it does not load at all and this is the result:

 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0

I tried it in Kali and in git bash and it comes out the same, is it a mistake by me or by the branch? Thank you very much.

You are trying in Kali or in Kali for WSL?

I present the same error when I was trying to install that in Kali for WSL and I follow this to fix it.

But you can follow this things:

you must have root or sudo permissions.

This is another way to install nix:

You can found that things in this Link

Thank you very much, I will see if it works for me with your advice, I am in Kali as such, I have it installed to the hard disk together with Windows and I have never had that error, I do not know if it is something that is wrong in the branch, thank you very much.